U e5då:ã@sldZddlZddlZddlZddlZzddlZdZWnek rLdZYnXddgZGdd„de ƒZ dZ d Z d Z d Ze eZd ZGd d„dƒZer®Gdd„deƒZe d¡edk�rhddlZeejdƒZee ¡ƒe ejd¡e ejd¡e ¡e ¡\ZZededƒD]BZ e !e ¡\Z"Z#Z$ede ƒe#D]Z%ede%ƒ�q@edƒ�qe &¡dS)z@A POP3 client class. Based on the J. Myers POP3 draft, Jan. 96 éNTFÚPOP3Ú error_protoc@s eZdZdS)rN)Ú__name__Ú __module__Ú __qualname__©rrú/usr/lib64/python3.8/poplib.pyrséniãó ó ic@s eZdZdZdZeejfdd„Zdd„Z dd„Z d d „Z d d „Z d d„Z dd„Zdd„Zdd„Zdd„Zdd„Zdd„Zdd„Zdd„Zd=d d!„Zd"d#„Zd$d%„Zd&d'„Zd(d)„Zd*d+„Zd,d-„Zd.d/„Ze d0¡Z d1d2„Z!d3d4„Z"d>d5d6„Z#d7d8„Z$d9d:„Z%d?d;d<„Z&dS)@raPThis class supports both the minimal and optional command sets. Arguments can be strings or integers (where appropriate) (e.g.: retr(1) and retr('1') both work equally well. Minimal Command Set: USER name user(name) PASS string pass_(string) STAT stat() LIST [msg] list(msg = None) RETR msg retr(msg) DELE msg dele(msg) NOOP noop() RSET rset() QUIT quit() Optional Commands (some servers support these): RPOP name rpop(name) APOP name digest apop(name, digest) TOP msg n top(msg, n) UIDL [msg] uidl(msg = None) CAPA capa() STLS stls() UTF8 utf8() Raises one exception: 'error_proto'. Instantiate with: POP3(hostname, port=110) NB: the POP protocol locks the mailbox from user authorization until QUIT, so be sure to get in, suck the messages, and quit, each time you access the mailbox. POP is a line-based protocol, which means large mail messages consume lots of python cycles reading them line-by-line. If it's available on your mail server, use IMAP4 instead, it doesn't suffer from the two problems above. zUTF-8cCsP||_||_d|_t d|||¡| |¡|_|j d¡|_d|_ |  ¡|_ dS)NFzpoplib.connectÚrbr) ÚhostÚportÚ_tls_establishedÚsysÚauditÚ_create_socketÚsockÚmakefileÚfileÚ _debuggingÚ_getrespÚwelcome)Úselfr rÚtimeoutrrrÚ__init__bs z POP3.__init__cCst |j|jf|¡S©N)ÚsocketZcreate_connectionr r)rrrrrrmszPOP3._create_socketcCs:|jdkrtdt|ƒƒt d||¡|j |t¡dS)Néz*put*zpoplib.putline)rÚprintÚreprrrrZsendallÚCRLF©rÚlinerrrÚ_putlineps z POP3._putlinecCs.|jrtdt|ƒƒt||jƒ}| |¡dS)Nz*cmd*)rrr ÚbytesÚencodingr$r"rrrÚ_putcmdxs z POP3._putcmdcCs |j td¡}t|ƒtkr$tdƒ‚|jdkr)rZpswdrrrÚpass_Ñsz POP3.pass_cCsF| d¡}| ¡}|jr&tdt|ƒƒt|dƒ}t|dƒ}||fS)z]Get mailbox status. Result is tuple of 2 ints (message count, mailbox size) ZSTATz*stat*ré)r8Úsplitrrr Úint)rZretvalZretsZ numMessagesZ sizeMessagesrrrÚstatÛs   z POP3.statNcCs |dk r| d|¡S| d¡S)aRequest listing, return result. Result without a message number argument is in form ['response', ['mesg_num octets', ...], octets]. Result when a message number argument is given is a single response: the "scan listing" for that message. NzLIST %sZLIST©r8r9©rÚwhichrrrr6ès z POP3.listcCs| d|¡S)zoRetrieve whole message number 'which'. Result is in form ['response', ['line', ...], octets]. zRETR %s©r9rGrrrÚretrösz POP3.retrcCs| d|¡S)zFDelete message number 'which'. Result is 'response'. zDELE %sr>rGrrrÚdeleþsz POP3.delecCs | d¡S)zXDoes nothing. One supposes the response indicates the server is alive. ZNOOPr>r:rrrÚnoopsz POP3.noopcCs | d¡S)z(Unmark all messages marked for deletion.ZRSETr>r:rrrÚrsetsz POP3.rsetcCs| d¡}| ¡|S)zDSignoff: commit changes on server, unlock mailbox, close connection.ZQUIT)r8Úclose)rr2rrrÚquits z POP3.quitcCsžz |j }d|_ |dk r| ¡W5|j}d|_|dk r˜zVz| tj¡Wn@tk rˆ}z"|jtjkrxt|ddƒdkrx‚W5d}~XYnXW5| ¡XXdS)z8Close the connection without assuming anything about it.NZwinerrorri&') rrNZshutdownrZ SHUT_RDWRÚOSErrorÚerrnoZENOTCONNÚgetattrr)rrÚexcrrrrrNs   ÿz POP3.closecCs| d|¡S)zNot sure what this does.zRPOP %sr>r?rrrÚrpop5sz POP3.rpops\+OK.[^<]*(<.*>)cCs\t||jƒ}|j |j¡}|s&tdƒ‚ddl}| d¡|}| |¡  ¡}|  d||f¡S)a Authorisation - only possible if server has supplied a timestamp in initial greeting. Args: user - mailbox user; password - mailbox password. NB: mailbox is locked by server from here to 'quit()' z!-ERR APOP not supported by serverrNrz APOP %s %s) r%r&Ú timestampÚmatchrrÚhashlibÚgroupZmd5Z hexdigestr8)rr@ZpasswordZsecretÚmrWZdigestrrrÚapop<s z POP3.apopcCs| d||f¡S)z­Retrieve message header of message number 'which' and first 'howmuch' lines of message body. Result is in form ['response', ['line', ...], octets]. z TOP %s %srI)rrHZhowmuchrrrÚtopQszPOP3.topcCs |dk r| d|¡S| d¡S)zìReturn message digest (unique id) list. If 'which', result contains unique id for that message in the form 'response mesgnum uid', otherwise result is the list ['response', ['mesgnum uid', ...], octets] NzUIDL %sZUIDLrFrGrrrÚuidlZsz POP3.uidlcCs | d¡S)zITry to enter UTF-8 mode (see RFC 6856). Returns server response. ZUTF8r>r:rrrÚutf8fsz POP3.utf8c Cspdd„}i}z4| d¡}|d}|D]}||ƒ\}}|||<q$Wn*tk rj}z tdƒ‚W5d}~XYnX|S)aReturn server capabilities (RFC 2449) as a dictionary >>> c=poplib.POP3('localhost') >>> c.capa() {'IMPLEMENTATION': ['Cyrus', 'POP3', 'server', 'v2.2.12'], 'TOP': [], 'LOGIN-DELAY': ['0'], 'AUTH-RESP-CODE': [], 'EXPIRE': ['NEVER'], 'USER': [], 'STLS': [], 'PIPELINING': [], 'UIDL': [], 'RESP-CODES': []} >>> Really, according to RFC 2449, the cyrus folks should avoid having the implementation split into multiple arguments... cSs"| d¡ ¡}|d|dd…fS)NÚasciirr)ÚdecoderC)r#ZlstrrrÚ _parsecapyszPOP3.capa.._parsecapZCAPArz!-ERR CAPA not supported by serverN)r9r) rr`Úcapsr2ZrawcapsZcaplineZcapnmZcapargsZ_errrrrÚcapals   z POP3.capacCsxts tdƒ‚|jrtdƒ‚| ¡}d|kr2tdƒ‚|dkrBt ¡}| d¡}|j|j|j d�|_|j  d¡|_ d|_|S) z{Start a TLS session on the active connection as specified in RFC 2595. context - a ssl.SSLContext z-ERR TLS support missingú$-ERR TLS session already establishedZSTLSz!-ERR STLS not supported by serverN©Zserver_hostnamer T) ÚHAVE_SSLrrrbÚsslÚ_create_stdlib_contextr8Ú wrap_socketrr rr)rÚcontextrar2rrrÚstls‰s  ÿz POP3.stls)N)N)N)'rrrÚ__doc__r&Ú POP3_PORTrÚ_GLOBAL_DEFAULT_TIMEOUTrrr$r'r/rr7r8r9r;r=r@rArEr6rJrKrLrMrOrNrTÚreÚcompilerUrZr[r\r]rbrjrrrrr3sB+ÿ       c@s8eZdZdZeddejdfdd„Zdd„Zd dd„Z dS) ÚPOP3_SSLaPOP3 client class over SSL connection Instantiate with: POP3_SSL(hostname, port=995, keyfile=None, certfile=None, context=None) hostname - the hostname of the pop3 over ssl server port - port number keyfile - PEM formatted file that contains your private key certfile - PEM formatted certificate chain file context - a ssl.SSLContext See the methods of the parent class POP3 for more documentation. NcCs’|dk r|dk rtdƒ‚|dk r0|dk r0tdƒ‚|dk s@|dk rVddl}| dtd¡||_||_|dkrxtj||d�}||_t   ||||¡dS)Nz4context and keyfile arguments are mutually exclusivez5context and certfile arguments are mutually exclusiverzAkeyfile and certfile are deprecated, use a custom context insteadrB)ÚcertfileÚkeyfile) Ú ValueErrorÚwarningsÚwarnÚDeprecationWarningrrrqrfrgrirr)rr rrrrqrrirtrrrr°s$ÿÿzPOP3_SSL.__init__cCs"t ||¡}|jj||jd�}|S)Nrd)rrrirhr )rrrrrrrÄs  ÿzPOP3_SSL._create_socketcCs tdƒ‚dS)z¬The method unconditionally raises an exception since the STLS command doesn't make any sense on an already established SSL/TLS session. rcN)r)rrrrqrirrrrjÊsz POP3_SSL.stls)NNN) rrrrkÚ POP3_SSL_PORTrrmrrrjrrrrrp¡sÿ rpÚ__main__rrBéz Message %d:z z-----------------------)'rkrQrnrrrfreÚ ImportErrorÚ__all__Ú Exceptionrrlrwr-ZLFr!r+rrpr5rÚargvÚarr;r@rAr6rEZnumMsgsZ totalSizeÚrangeÚirJÚheaderÚmsgr.r#rOrrrrÚsL n0